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Overview
This guide describes the installation and functionality of the OpenProtocols for Microsoft Outlook.
The OpenProtocols connector for Microsoft Outlook extends Outlook to allow connectivity with a wider array of
messaging service providers. Once the connector is installed, Outlook can integrate with Cloud based services to provide
integrated Calendars, Contacts and Tasks (via IMAP, CalDAV and CardDAV respectively).
The connector offers two levels of integration. It can be used either as a complete message service (with a similar
experience to connecting to Microsoft Exchange), or it can simply connect existing Outlook folders with server collections.

Features
The OpenProtocols Connector for Microsoft Outlook has the following features:









Full integration of email, appointments, tasks and address book
Access the global address directory if available
Offline support
Support for SSL connections to the server
Supports a complete set of Outlook Appointment and Contact Properties
Supports preservation of extended Outlook Properties (whereby it caches them and submits them to the server
on updates
Allows simple exporting of Contact/Appointment folders to CardDAV/CalDAV services
Allows users to create additional folders and bind them with DAV collections

Requirements
The server needs to support IMAP for email, CalDAV for calendaring and CardDAV for contacts. If the CardDAV server
supports a global directory, this will be available. For the client application, you can use the following:






Microsoft Outlook 2003 (with Office SP3)
Microsoft Outlook 2007
Microsoft Outlook 2010 (32bit and 64bit versions)
Microsoft Outlook 2013 (32bit and 64bit versions)
Microsoft Outlook 2016 (32bit and 64bit versions)

Installation
You should close Microsoft Outlook and run the installation application for the connector.
The connector will then guide you through the installation process (which basically only involves specifying the installation
location).
Once the connector has been installed, you can then launch Microsoft Outlook.
If you already have configured Outlook with an e-mail account, you may wish to simply open that account, and nominate
the folders you wish to connect with DAV service providers (this is the simplest way to achieve CalDAV/CardDAV
integration within Outlook). This is explained under the “Outlook Binding Configuration”
Alternatively, you can add a new account and connect to an existing message service provider. This is explained under the
“Outlook Account Configuration” section.

Outlook Binding Configuration
Binding a Folder
For existing Outlook users, when you attempt to click on a Calendar/Contact folder, you will be prompted as to whether to
bind it with a collection.

If “Yes” is clicked, the Folder binding dialog will appear. This dialog allows the user to specify the settings for the target
DAV collection.

Once the user’s e-mail address and password are specified, the user can click the Resolve button.

If the Resource is left blank, then the client will attempt to use auto-discovery to determine any resources that might be
available. Alternatively, you can specify the location for the resource based on your service provider’s documentation.

Once you click OK. The folder will then be bound to the server collection.

Binding Additional Folders

The connector adds an additional menu to the Outlook Toolbar/Ribbon.
This is shown below:

The SERVER menu on the Outlook Ribbon can be used to configure the binding (if necessary).
It provides the following features:
Option
Connection
Export..
Update
Reset from Server
Hide Download Progress
Logging
Restore..
Options

Description
Allows you to either bind a folder to a DAV collection or to manage the binding
settings
Allows you to export a folder to a CalDAV/CardDAV service
Reconciles Outlook with the bound CalDAV/CardDAV service
Removes all client folder contents from hosted service
Determines whether the client shows interactive status messages when it
synchronises items
Allows logging settings to be configured
Will restore a cached version of calendar/contact items (typically used for recovery
if items accidently are deleted)
Allows the configuration of client licensing and connector options

Outlook Account Configuration
The OpenProtocols connector communicates to the mail server via the IMAP and SMTP services. A default installation
would require the client machine to access the server over ports 143 and 25, although this is configurable. If SSL is being
used, the client port configuration must match the server SSL port configuration.

Configuring an Outlook Account
Creating an Account
Adding an account to an existing profile in Outlook 2007:
1.
2.
3.
4.

Select Account Settings from the Tools menu.
Select the New... link to create a new account.
Select Other and the Open Protocols Server option, then select Next.
You can now configure the account as per the steps in Configuring an Account.

Adding an account to an existing profile in Outlook 2010:
1.
2.
3.
4.

Select the File menu item and click the Add Account button under the Account Information heading
Select the Manually configure server settings of additional server types option, then select Next.
Select Other and the Open Protocols Server option, then select Next
You can now configure the account as per the steps in Configuring an Account.

Adding an account to an existing profile in Outlook 2013:
1.
2.
3.
4.

Select the File menu item and click the Add Account button under the Account Information heading
Select the Manual setup or additional server types option, then select Next.
Select Other and the Open Protocols Server option, then select Next
You can now configure the account as per the steps in Configuring an Account.

Configuring an Account
You can now configure the settings for connecting and accessing the mail server. For simple account configuration you
only need to fill out the data on the General tab.

Option
Email Address
Password
Detect Settings

Server Address
User Name
Your Name
Account Description
Enable advanced
configuration

Description
The email address that will be used to send the email.
The mailbox password.
This button can be clicked in order to have the connector try to auto-fill the rest of
the account details. The email address will be used to determine the rest of the
settings.
The domain or the IP address of the mail server.
The username for the mailbox to log into.
This is the friendly name which is show on the emails being send, normally the first
name and surname.
A name to identify the mailbox, and is the name Outlook displays when listing the
account.
When enabled, this will show other configuration tab pages where more advanced
options can be configured.

The Mailbox tab allows more advanced options with the mailbox connections to be set:

Option
Server Address
Port Number

Use SSL
User Name
Password

Description
The domain or the IP address of the mail server.
The port that the connector will connect to on the server. The connector needs to
connect to the IMAP service running on the server, so this would normally be 143.
For SSL this is normally 993.
If SSL is configured on the IMAP service then you are able to enable this.
The username for the mailbox to log into.
The mailbox password.

The Outbound tab allows you to configure extra outbound options:

Option
Sender Name

Description
This is the friendly name which is show on the emails being send, normally the first
name and surname.
Email Address
The email address to send as.
Reply To Address
The email address to be used as the Reply-To address in the emails sent. Normally
this will be the same as the email address.
Send mail on behalf of
This option is select if you want to send email on behalf of someone else. This
another person
changes the From address in the email header to be the display name and email
address configured here, and uses the sender name and email address as the
Sender address in the email header.
Display Name
The friendly name to be used for the From address when sending on behalf of
someone.
Email Address
The email address to be used for the From address when sending on behalf of
someone.
Use same settings as for
Usually when sending email you would authenticate using the same mailbox
mailbox connection
details as you are logging in for, so this option would be enabled. If you need to
authenticate as another user when sending email you can set the options here.
Server Address
The domain or the IP address of the mail server.
Port Number
The port number of the SMTP service.
Use SSL
If SSL is configured on the server for an SMTP port, you can select it here.
Account Name
The username to authenticate with.
Password
The password to authenticate with.
The Connection table allows the changing of connection specific options:

Option
Update folders at startup

Download entire
messages

Description
If this is enabled, when Outlook is started the client will check every server folder
and sync these with the client. This will slow down opening the account initially,
but may help if the mailbox has other users who access it at the same time.
If you have a fast link to the mail server (if it was on your local network), then
selecting this option will help reduce delays when new messages arrive, as the
connector will try to download the full message as soon as it is available. By
default the connector will only download some of the message details until the
message is selected.

The Troubleshooting tab is used to configure options for diagnosing problems:

Option
Troubleshooting mode

Disable concurrent
downloading and
synchronisation
Enable logging

Logging level
New files each session

Automatically update
contact address labels
Automatically check for
software updates

Description
When enabled, more work is done when syncing the client cache with the server
content, to make sure they match. This slows down any synchronisation, so only
enable if requested to.
This will force the connector to only process one folder at a time. Only enable if
instructed to, as it will slow down the synchronisation process.
The connector has extensive logging, which is designed to help the support team
to diagnose any issues. Log files can get very large (gigabytes in size if Outlook is
left running for a while), so only enable this if instructed to by a support person,
and make sure you disable when the required logs are generated.
How much information will be logged to the log files. Full Detail will generate large
log files.
Whenever Outlook is started with logging turned on, the log file will be
overwritten. If you want to keep log files whenever closing and opening Outlook
you will need to enable this option.
Updating Outlooks contact labels immediately adds some overhead to the
connection, so it is able to be disabled here to improve performance if needed.
When Microsoft Outlook is started, the connector will check to see whether a new
version of the connector is available. It is able to then download this for you and
start the installation process.

Initial Connection
When a connection is first made to the mail server by the client connector, all the mailbox contents from the server are
copied to the local profile. If you are connecting to a mailbox with a lot of email data, be aware that it can take time to do
the initial connection.

Outlook Menu
The connector adds another ribbon bar item to Outlook, called Server. The following items can be accessed:
Refresh Folder List: Synchronises the list of folders between the client and the server.
Reset Folder From Server: Empties the currently selected folder from the client and downloads the contents from the
server.
Check Folder for New Messages: Performs a synchronisation with the server on the currently selected folder, checking
whether it is up to date, and downloading any missing messages, updating changed messages, and removing deleted
messages.

Offline Support
When configured as an Outlook account/message service, if a connection is not available to the server, you are still able to
use Microsoft Outlook to read, reply and to change flags for messages (the message has to have previously been
downloaded to Outlook for this to work). You are not able to do folder manipulation or delete messages. Appointments,
tasks and contacts can be created and edited. When a server connection is available again, your previous changes will be
synchronised with the server.

Server Folder Synchronisation
The mail server does not give notifications of folder changes, such as new folders, or removing folders. So if you remove a
folder in webmail while you have an Outlook connector client connected, it will not know the folder has been removed,
and it will still be visible. In order to have the client update the folders, go into the account settings and click the Enable
advanced configuration checkbox. Then click the Connection tab that appears and select the Update folders at start-up
checkbox. This will force Outlook to check the folders on the server when Outlook is opened.

Microsoft Outlook Add-ins
Much of the behaviour provided by the connector is by Outlook add-ins. There are two alternative add-ins, an Exchange
Client Extension (not available in Outlook 2010), and a COM add-in. They both provide the same features. If neither add-in
is enabled, you will not have the full synchronisation experience. The procedure for checking the state of the add-ins and
enabling them varies with different versions of Outlook.

For Outlook 2003:
Select the Tools > Options menu. Click the Other tab in the window that appears, click the Advanced Options
button. Select the Add-In Manager button. In the Add-In Manager window that opens, find the "MailEnable"
entry and ensure it is ticked to enable it.

For Outlook 2007:
Go to the Tools menu and select the Trust Center. In the list on the left of the "Trust Center" window, select Addins. In the drop down list labelled "Manage:" at the bottom of the right hand panel, select Exchange Client
Extensions and click the Go button. In the Add-In Manager window that opens, find the "MailEnable" entry and
ensure it is ticked to enable it. If it is not visible, then click the Add… button and select the MailEnableMS32.dll file
from the Windows system32 directory (normally c:\Windows\system32).

For Outlook 2010/2013:
Go to the File menu and select Options. In the window which appears, select the Add-ins option. In the drop
down list labelled "Manage:" at the bottom of the right hand panel, select COM Add-ins and click the Go button.
In the "COM Add-Ins" dialog that opens, look for the option MailEnable Connector for Outlook Add-in, and
ensure it is ticked to enable it. If it is not visible, then click the Add… button and select the MailEnableMS32.dll file
from the Windows system32 directory (normally c:\Windows\system32).

Importing Email Data
You are able to import email from an existing PST file to an Outlook connector account. Be aware though that when you
do this, all the email being imported has to also be uploaded to the server. So importing large mailboxes may take a long
time, depending on the clients Internet connection.

Moving Outlook Connector PST files
When configured as an Outlook account/message service, it is not possible to change the location of a PST file once an
account is created with the Outlook connector. There is not a way to configure the location of the PST files, and the
connector will always use the Windows APPDATA environment variable to determine where to store the local cache.

Limitations
1. When configured as an Outlook account/message service, messages that have not been downloaded from the
server will show only their downloaded size when sorting, not their complete size.
2. Exceptions to recurring appointments are only kept locally to Outlook. They may not be integrated with the
backend service (because many do not support appointment exceptions).
3. When configured as an Outlook account/message service, Mark All as Read for folder is not available.
4. When configured as an Outlook account/message service, Custom special folders are not supported by the
connector.
5. The global directory is only loaded when Outlook starts. So new contacts added to the global directory will not be
visible immediately.
6. When configured as an Outlook account/message service, BCC addresses are not visible for messages in the Sent
Items folder.
7. When configured as an Outlook account/message service, Outlook rules are not able to be processed unless
Outlook is open at the time the message arrives. If you use rules, after loading Outlook run the rules manually.

FAQ
Q. When trying to save a reminder, I get an error indicating that the folder does not support this type of item.
A. Reminders are only supported on the default store for the profile you are using. If you are using multiple
accounts in a profile, you can change the default by using the Mail control panel applet.
Q. While composing a message with a large attachment, Outlook seems to freeze for a while.
A. The Connector will save a message being composed to the Drafts folder depending on your Outlook settings.
Since the Drafts folder is stored on the server, the Connector will be uploading it. You can increase the time
before Outlook saves to Drafts in the Outlook options.
Q. Which account are my Draft messages saved to?
A. If you have multiple email accounts configured under the one profile then draft messages will be stored in the
default account.

